Difference between revisions of "Installation of yade on debian / ubuntu"

From Yade

(Latest development version from sources)
Line 1: Line 1:
''Warning :'' helpful informations can be found on this page, but the most up-to-date is in [https://www.yade-dem.org/sphinx/installation.html]
+
''Warning :'' helpful informations can be found on this page, but the most up-to-date is in [https://www.yade-dem.org/doc/installation.html]
  
 
You should be running at least Debian Squeeze / Ubuntu Hardy Heron (8.04) to have required version of dependencies.
 
You should be running at least Debian Squeeze / Ubuntu Hardy Heron (8.04) to have required version of dependencies.

Revision as of 13:46, 16 September 2013

Warning : helpful informations can be found on this page, but the most up-to-date is in [1]

You should be running at least Debian Squeeze / Ubuntu Hardy Heron (8.04) to have required version of dependencies.

Using prepackaged version

You can use pre-compiled packages build by launchpad PPA service once in a while, if you are running Ubuntu.

Latest development version from sources

Sources can be downloaded using Bazaar. Check this short tutorial.

After downloading the sources you'll have to install a number of packages. Some are optional, others are not.

Cut&paste the following commands to terminal for Ubuntu

sudo aptitude install scons libqt3-mt-dev qt3-dev-tools freeglut3-dev \
libboost-date-time-dev libboost-filesystem-dev libboost-thread-dev \
libboost-regex-dev fakeroot dpkg-dev build-essential g++ \
libboost-iostreams-dev liblog4cxx10-dev python-dev libboost-python-dev ipython \
python-matplotlib libsqlite3-dev python-numeric python-tk gnuplot doxygen \
libgts-dev python-pygraphviz libvtk5-dev python-scientific bzr libeigen2-dev \
libqglviewer-qt3-dev libloki-dev python-xlib python-qt4 libqglviewer-qt4-dev \
pyqt4-dev-tools

Cut&paste the following commands to terminal for Debian Squeeze (as root)

apt-get install bzr scons cmake libxi-dev freeglut3-dev libloki-dev libboost-date-time-dev \
libboost-filesystem-dev libboost-thread-dev libboost-regex-dev fakeroot dpkg-dev \
build-essential g++ libboost-iostreams-dev liblog4cxx10-dev python-dev \
libboost-python-dev ipython python-matplotlib libsqlite3-dev python-numpy \
python-tk gnuplot doxygen libgts-dev python-pygraphviz libvtk5-dev python-scientific\
libeigen2-dev binutils-gold python-xlib python-qt4 pyqt4-dev-tools \
libqglviewer-qt4-dev python-imaging libjs-jquery gdb sqlite3 libvtk5-qt4-dev libvtk5-dev

Now get the code and compile with scons (NOT as root !)

bzr checkout --lightweight lp:yade
cd yade
scons profile=default features=gts,log4cxx,opengl,openmp,vtk,qt4 version=trunk linkStrategy=monolithic PREFIX=~/yade
yade-trunk

Stable version from sources

Installing dependecies (cut&paste to terminal all together):

sudo aptitude install scons libqt3-mt-dev qt3-dev-tools freeglut3-dev \   
libboost-date-time-dev libboost-filesystem-dev libboost-thread-dev \   
libboost-regex-dev fakeroot dpkg-dev build-essential g++ \   
libboost-iostreams-dev liblog4cxx10-dev python-dev libboost-python-dev ipython \   
python-matplotlib libsqlite3-dev python-numeric python-tk gnuplot doxygen \
libgts-dev python-pygraphviz libvtk5-dev python-scientific


Make sure that you have boost 1.34 or higher

Download and compile Yade

Grab the latest release from Launchpad download page

scons # installs to /usr/local by default

Other possible options are available with 'scons -h' command

Be sure to check out scons options on installation details page for optimized builds or different installation directory.